Jakarta Servlet
4.0
3.1
5.0

This feature enables support for HTTP Servlets written to the Jakarta Servlet 5.0 specification. You can package servlets in Jakarta EE specified WAR or EAR files. If servlet security is required, you should also configure an appSecurity feature. Without a security feature, any security constraints for the application are ignored.

Enabling this feature

To enable the Jakarta Servlet 5.0 feature, add the following element declaration into your server.xml file, inside the featureManager element:

<feature>servlet-5.0</feature>

Standard API packages provided by this feature

  • jakarta.servlet

  • jakarta.servlet.annotation

  • jakarta.servlet.descriptor

  • jakarta.servlet.http

  • jakarta.servlet.resources

Liberty API packages provided by this feature

  • com.ibm.websphere.servlet.container

  • com.ibm.websphere.servlet.context

  • com.ibm.websphere.servlet.error

  • com.ibm.websphere.servlet.event

  • com.ibm.websphere.servlet.session

  • com.ibm.websphere.webcontainer

  • com.ibm.wsspi.servlet.session

Supported Java versions

  • JavaSE-1.8

  • JavaSE-11.0

  • JavaSE-17.0

  • JavaSE-18.0

Developing a feature that depends on this feature

If you are developing a feature that depends on this feature, include the following item in the Subsystem-Content header in your feature manifest file.

com.ibm.websphere.appserver.servlet-5.0; type="osgi.subsystem.feature"

SPI packages provided by this feature

  • com.ibm.websphere.servlet.filter

  • com.ibm.websphere.servlet.request

  • com.ibm.websphere.servlet.response

  • com.ibm.websphere.webcontainer.async

  • com.ibm.ws.webcontainer.extension

  • com.ibm.ws.webcontainer.spiadapter.collaborator

  • com.ibm.wsspi.webcontainer

  • com.ibm.wsspi.webcontainer.collaborator

  • com.ibm.wsspi.webcontainer.extension

  • com.ibm.wsspi.webcontainer.filter

  • com.ibm.wsspi.webcontainer.metadata

  • com.ibm.wsspi.webcontainer.osgi.extension

  • com.ibm.wsspi.webcontainer.servlet

  • com.ibm.wsspi.webcontainer.webapp